如何禁用WordPress的自动更新

新的WordPress增加了自动更新的功能,更新是好的,但有时候我们不一定希望它自动执行。尽管风险很小,但有时更新可能会出错。发生这种情况时,最好是坐在计算机旁而不是在游泳池旁。

为此,本文准备了两种可以用来关闭WordPress网站上的自动更新的方法。

默认情况下,WordPress自动WordPress更新如何工作?

WordPress执行四种不同类型的自动更新。但是,默认情况下,并非所有功能都启用。

这四种更新类型是:

  • 核心更新
  • 插件更新
  • 主题更新
  • 翻译文件更新

核心更新类别进一步细分为三种不同类型:

  • 核心开发更新 – WordPress的最新开发版本,即使有可能不稳定。
  • 主要核心更新 –像WordPress 5.4这样的主要版本
  • 次要核心更新 –维护或安全性发布(例如5.4.1,包含主要核心更新)

默认情况下,WordPress仅启用两种类型的自动更新:

  • 次要核心更新
  • 翻译文件更新

此外,WordPress安全团队确实能够在极端情况下(例如,重大安全漏洞)对某些主题或插件强制推送更新,但是这种情况很少。如果愿意,也可以关闭此功能。

在介绍如何在WordPress网站上禁用自动更新之前,想提醒大家,自动更新在大多数情况下是一件好事。如果出现新的漏洞,如WordPress 4.7.2中的REST API漏洞,自动更新可以使网站免于潜在的麻烦。

因此,即使禁用了自动更新,仍然需要保持最重要的状态以确保网站安全。

如何禁用自动更新–无需插件

仅需编辑wp-config.php文件,即可关闭自动更新或关闭某些类型的自动更新。

要全面禁用每种类型的自动更新,只需将以下代码片段添加到wp-config.php文件的末尾:

define( 'AUTOMATIC_UPDATER_DISABLED', true );

仅禁用所有核心更新,可以使用以下代码:

define( 'WP_AUTO_UPDATE_CORE', false );

要禁用主要更新和开发更新,可以使用此代码段。 次要更新仍处于启用状态:

define( 'WP_AUTO_UPDATE_CORE', minor );

禁用主题和插件的自动更新,可在functions.php文件中添加相应代码。

要禁用所有插件更新(包括强制推送),可以使用以下代码段:

add_filter( 'auto_update_plugin', '__return_false' );

要禁用所有主题更新(包括强制推送),可以使用以下代码段:

add_filter( 'auto_update_theme', '__return_false' );

如何使用插件实现禁用自动更新

要禁用带有插件的自动更新,推荐免费的Easy Updates Manager插件。原因如下:

  • 插件安装超过100,000次
  • 用户评价达到5星级
  • 开发人员的定期更新
  • 100%免费

此外,插件还可以对更新进行详细控制。可以单独启用/禁用特定主题或插件的自动更新。


  • 微信或QQ扫一扫

留下评论