WordPress 5.9.3 更新已发布

2022 年 4 月 5 日(北京时间4月6日),WordPress 5.9.3 向公众发布,5.9.3 是一个短周期维护版本,下一个主要版本将是 6.0 版。该版本修复了 9 个核心错误、 10 个块编辑器错误。

可以从 WordPress.org 下载 WordPress 5.9.3,或访问您的仪表板 → 更新并单击“立即更新”。

5.9.3 版本由 Jb Audras 和 George Mamadashvili 领导。

WordPress核心修复清单

  • #52409  – 文件系统 API:包括 ssh-ed25519 公钥签名算法作为替代 ssh-rsa
  • #54878  – 主题:安装后隐藏块主题实时预览链接
  • #54916  – 管理:当活动主题是块主题时,不要为小部件菜单指定菜单顺序
  • #54939  – 定制器:当块主题处于活动状态时,在定制器中添加有关站点编辑器的信息
  • #55203  – 媒体: get_post_galleries() 只制作返回画廊
  • #55241  – 主题:避免未定义的变量警告 get_svg_filters()
  • #55311  – 编辑器:在常规目录之外使用 WP 时修复损坏的资产 URL
  • #55337  – 编辑器:优化帖子和站点编辑器的预加载路径
  • #55474  – 更新 5.9.3 的 WordPress 包

块编辑器修复清单

  • PR38136  – 将 aria-label 添加到搜索按钮,作为可访问性增强
  • PR38863  – 模板列表:解码记录标题中的实体
  • PR38891  – 使用 wp_unique_id() 而不是 uniqid() 生成 CSS 类名
  • PR38765  – 封面块:修复渐变叠加(删除黑色背景颜色)
  • PR39045  – 尝试:修复图像响应规则
  • PR38762 – 通过删除过时的  伪元素 修复 #38761::before
  • PR39091  – 删除“样式”设置时避免错误
  • PR39164  – 更改块支持样式的位置 <head>
  • PR39340  – 图片:恢复块中的基线响应能力
  • PR39445  – 修复:表格块不保留背景颜色

更新包列表

@wordpress/[email protected]
@wordpress/[email protected]
@wordpress/[email protected]
@wordpress/[email protected]
@wordpress/[email protected]
@wordpress/[email protected]

修订文件清单

wp-admin/about.php
wp-admin/css/customize-controls-rtl.css
wp-admin/css/customize-controls-rtl.min.css
wp-admin/css/customize-controls.css
wp-admin/css/customize-controls.min.css
wp-admin/customize.php
wp-admin/edit-form-b​​locks.php
wp-admin/includes/ajax-actions.php
wp-admin/includes/class-wp-filesystem-ssh2.php
wp-admin/js/customize-controls.js
wp-admin/js/customize-controls.min.js
wp-admin/js/theme.js
wp-admin/js/theme.min.js
wp-admin/site-editor.php
wp-admin/theme-install.php
wp-includes/assets/script-loader-packages.php
wp-includes/block-supports/duotone.php
wp-includes/block-supports/elements.php
wp-includes/block-supports/layout.php
wp-includes/blocks.php
wp-includes/blocks/archives.php
wp-includes/blocks/cover/style-rtl.css
wp-includes/blocks/cover/style-rtl.min.css
wp-includes/blocks/cover/style.css
wp-includes/blocks/cover/style.min.css
wp-includes/blocks/image/style-rtl.css
wp-includes/blocks/image/style-rtl.min.css
wp-includes/blocks/image/style.css
wp-includes/blocks/image/style.min.css
wp-includes/blocks/navigation.php
wp-includes/blocks/search.php
wp-includes/class-wp-theme-json.php
wp-includes/css/dist/block-library/common-rtl.css
wp-includes/css/dist/block-library/common-rtl.min.css
wp-includes/css/dist/block-library/common.css
wp-includes/css/dist/block-library/common.min.css
wp-includes/css/dist/block-library/style-rtl.css
wp-includes/css/dist/block-library/style-rtl.min.css
wp-includes/css/dist/block-library/style.css
wp-includes/css/dist/block-library/style.min.css
wp-includes/functions.php
wp-includes/js/dist/block-library.js
wp-includes/js/dist/block-library.min.js
wp-includes/js/dist/edit-post.js
wp-includes/js/dist/edit-post.min.js
wp-includes/js/dist/edit-site.js
wp-includes/js/dist/edit-site.min.js
wp-includes/media.php
wp-includes/script-loader.php
wp-includes/version.php

建议所有WordPress 5.9.x 版本的用户升级,暂时未发现主流插件主题与该版本存在兼容性问题。

站长帮社区

建站技术交流社区,欢迎提问与交流,还有大量WordPress主题与插件。

发表评论